X-52 issues with new PC (fixed!)

Community Support for the machines running the game
Jeffers2112
Expert
Expert
Posts: 362
Joined: Thu Mar 05, 2015 4:59 pm
CMDR: Jasper Randall
CMDR_Platform: PC-MAC
Contact:

X-52 issues with new PC (fixed!)

Postby Jeffers2112 » Sat Dec 31, 2016 5:59 pm

So I've gotten myself a nice new gaming PC for my birthday.
I'm reinstalling games and such and get to Elite. I'd been a clever lad and saved my custom controls file and my Saitek X-52 profile file, which has been working nicely for ages.
Unfortunately when it came to playing the game I had some issues.
A couple of commands that I'd mapped to buttons 31 & 32 no longer worked.
If I tried to re-assign them Elite insisted on seeing button 31 as left mouse, and just didn't recognise XB32 at all.
So after double-checking my profile and re-loading the saved files a few times to no avail I was getting rather frustrated to say the least.
Then a search threw up mention of X-52 problems with USB3 ports.
My old PC had only had USB2 but my new one has both. I'd plugged my X-52 into a USB3 port simply because it was the first empty port I'd come across when connecting up.
So I moved it to a USB2 port and, voila! problem solved....
So a caution, if you do upgrade systems do try and keep the controller connections the same as the old (working!) setup.
Image

User avatar
JohnLuke
Deadly
Deadly
Posts: 5022
Joined: Sun Apr 19, 2015 10:24 am
CMDR: JohnLuke
CMDR_Platform: PC-MAC
Contact:

Re: X-52 issues with new PC (fixed!)

Postby JohnLuke » Sat Dec 31, 2016 8:08 pm

Good tip, Jasper. Thanks for sharing!
-JL

Discord Admin
Forum moderator
FB Group moderator

Image


Return to “Hardware and Technical”

Who is online

Users browsing this forum: No registered users and 3 guests

i